Town Square

Post a New Topic

Anyone else had power outage?

Original post made by Sw, Palo Verde, on Feb 23, 2012

We just had all our electricity go out with a strange noise......experienced total darkness for a few seconds, and then everything went back on. Wondering if we have an electrical problem in our house or if others had the same thing happen.

Comments (13)

 +   Like this comment
Posted by Person
a resident of Fairmeadow
on Feb 23, 2012 at 11:27 pm

Same, heard some sort of explosion/bang noise outside in the distance. I'm guessing something blew, but the system had a backup in place that had power back up and running. Glad the power came back, last time something blew(that I vividly remember) was in the middle of the night a couple years ago and power was out for a couple hours.


 +   Like this comment
Posted by homeowner
a resident of South of Midtown
on Feb 23, 2012 at 11:27 pm

Yep... same thing happened here... there was also a loud bang that sounded like it came from the area around Charleston and Middlefield or east meadow and middlefield.


 +   Like this comment
Posted by MK
a resident of Palo Verde
on Feb 23, 2012 at 11:27 pm

We experienced the outage also and heard a loud "explosion." We live near the YMCA.


 +   Like this comment
Posted by another person
a resident of Palo Verde
on Feb 23, 2012 at 11:43 pm

I also live near the YMCA and it happened. The boom sound was pretty loud. Rumor is that it was a fallen lamp post.


 +   Like this comment
Posted by JC
a resident of Palo Verde
on Feb 23, 2012 at 11:55 pm

I thought my lightbulb went out, until I heard from everyone that the power went out. My family said they heard a boom too, (as did my grandma who lives in Colorado Park apartments) though I didn't b/c I was showering. It came back on after a few seconds so I guess it wasn't serious?


 +   Like this comment
Posted by Anon.
a resident of Crescent Park
on Feb 24, 2012 at 12:14 am

What time was this … my computers rebooted about an hour ago for no reason and the stove clock is blinking. All the rest of the lights and stuff are still on. I am in the Crescent Park area.


 +   Like this comment
Posted by Mozelle
a resident of Ohlone School
on Feb 24, 2012 at 12:59 am

I had the same experience, near Ohlone School. It fixed the Internet connection problem I was having. It did sound like something blew.


 +   Like this comment
Posted by buffula
a resident of Palo Verde
on Feb 24, 2012 at 3:45 am

Same here. Everything went dark with a clanging buzz 4.5 hrs ago at 2315. Power only out for about a minute. Sounded like it was on my roof. Wondered if it was an animal on my power line or tv dish. Power came back on. Been fine since....other than blinking clocks.


 +   Like this comment
Posted by MidtownMom
a resident of Midtown
on Feb 24, 2012 at 6:37 am

Loud boom around 11:30pm .. power went out for a minute or less .. though long enough to reboot / rest systems. Close to YMCA ..


 +   Like this comment
Posted by Resident
a resident of Another Palo Alto neighborhood
on Feb 24, 2012 at 11:10 am

I assume that this was a transformer blowing somewhere, and the power was diverted to a backup. It happened at a time when our family was just settling for the night and got everyone up and wide awake again for another 30 minutes.

It would be nice to know more details though.


 +   Like this comment
Posted by Resident
a resident of Another Palo Alto neighborhood
on Feb 24, 2012 at 3:26 pm

PAW

Many people seem to think that this power outage and the large bang had something to do with the death on the tracks last night.

Please can you clear this up and let us know if these were connected and if not, where the bang originated.

Thank you.


 +   Like this comment
Posted by city says
a resident of Adobe-Meadows
on Feb 25, 2012 at 2:33 pm

The city web site says:

"Thursday, February 23: At 11:15pm a faulty transformer switch caused a one minute power outage throughout the entire City. Power was rerouted and restored immediately. Crews isolated the faulty switch and will be replacing it."

Web Link


 +   Like this comment
Posted by city says
a resident of Adobe-Meadows
on Feb 25, 2012 at 2:35 pm

P.S. If the time on the city report is correct, the Caltrain fatality at 10:10pm was more than 1 hour earlier.


Don't miss out on the discussion!
Sign up to be notified of new comments on this topic.

Email:


Post a comment

Posting an item on Town Square is simple and requires no registration. Just complete this form and hit "submit" and your topic will appear online. Please be respectful and truthful in your postings so Town Square will continue to be a thoughtful gathering place for sharing community information and opinion. All postings are subject to our TERMS OF USE, and may be deleted if deemed inappropriate by our staff.

We prefer that you use your real name, but you may use any "member" name you wish.

Name: *

Select your neighborhood or school community: * Not sure?

Comment: *

Verification code: *
Enter the verification code exactly as shown, using capital and lowercase letters, in the multi-colored box.

*Required Fields

Early Decision Blues
By John Raftrey and Lori McCormick | 0 comments | 2,373 views

One night only: ‘Occupy the Farm’ screening in Palo Alto
By Elena Kadvany | 1 comment | 2,229 views

First Interview
By Sally Torbey | 10 comments | 1,429 views

Death with Dignity
By Chandrama Anderson | 3 comments | 1,415 views

Guest Post #2 from HSSV: Labradoodle Back on His Feet
By Cathy Kirkman | 3 comments | 488 views